Обмен через Конвертацию данных 2.1 во внешней обработке + Запуск внешней обработки по расписанию (БСП)

Публикация № 1183082

Разработка - Системная интеграция - Обмен через XML

Сделаем ежедневную выгрузку и загрузку данных через конвертацию данных 2.1 из одной базы в другую. Но весь код и правила конвертации будут располагаться во внешней обработке.

Создадим План обмена и два узла. В узел "Изменения" будут регистрироваться все изменения в базе источнике. В узел "Выгрузка" будем перед выгрузкой регистрировать изменения и очищать узел "Изменения". Делаю так, чтобы избежать блокировок и если что-то пойдет не так во время выгрузки, то в узле "Выгрузка" останутся объекты, которые небыли выгружены.

 

 

Создаем внешнюю обработку. В макет добавляем Правила обмена данными (Конвертация данных 2.1)

 

 

В модуле обработки описываем сведения о обработке. Тут важно указать НоваяКоманда.Использование = "ВызовСерверногоМетода";

 

 

Функция СведенияОВнешнейОбработке() Экспорт
		
	ТЗКоманды = Новый ТаблицаЗначений;
	ТЗКоманды.Колонки.Добавить("Представление");
	ТЗКоманды.Колонки.Добавить("Идентификатор");
	ТЗКоманды.Колонки.Добавить("Использование");
	ТЗКоманды.Колонки.Добавить("ПоказыватьОповещение"); 
	ТЗКоманды.Колонки.Добавить("Модификатор");
	
	НоваяКоманда = ТЗКоманды.Добавить();
	НоваяКоманда.Представление = "Выгрузка данных в базу Бухгалтерии";
	НоваяКоманда.Идентификатор = "ВыгрузкаДанныхВБазуБух";
	НоваяКоманда.Использование = "ВызовСерверногоМетода"; 
	НоваяКоманда.ПоказыватьОповещение = Истина;
	НоваяКоманда.Модификатор = "";
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Наименование", "Выгрузка данных в базу Бухгалтерии"); 
	ПараметрыРегистрации.Вставить("Информация", ""); 
	ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");  
	ПараметрыРегистрации.Вставить("Версия", "1.0");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
	ПараметрыРегистрации.Вставить("Команды", ТЗКоманды);

	Возврат ПараметрыРегистрации;
	
КонецФункции

Добавляем процедуру ВыполнитьКоманду. Эта процедура и будет вызваться при Запуске по расписанию

 

 

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды = Неопределено) Экспорт

КонецПроцедуры

Добавляем обработку в дополнительные обработки. Ставим галочку расписание и устанавливаем расписание.

 

 

В теле процедуры ВыполнитьКоманду:

1. - Определяем переменные, которые нам понадобятся.

- Запросом получаем "Дату запрета изменений" - эта дата будет датой начала выгрузки.

- Определяю массив выгружаемых объектов (по нему в цикле будем формировать текст запроса).

 

 

Запрос = Новый Запрос;
ДатаНачала = Дата(2019,1,1);
Запрос.Текст = 
	"ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
	|	ДОБАВИТЬКДАТЕ(ДатыЗапретаИзменения.ДатаЗапрета, ДЕНЬ, 1) КАК ДатаЗапрета
	|ИЗ
	|	РегистрСведений.ДатыЗапретаИзменения КАК ДатыЗапретаИзменения
	|ГДЕ
	|	ДатыЗапретаИзменения.Раздел = ЗНАЧЕНИЕ(ПланВидовХарактеристик.РазделыДатЗапретаИзменения.ПустаяСсылка)
	|	И ДатыЗапретаИзменения.Объект = ЗНАЧЕНИЕ(ПланВидовХарактеристик.РазделыДатЗапретаИзменения.ПустаяСсылка)
	|	И ДатыЗапретаИзменения.Пользователь = ЗНАЧЕНИЕ(перечисление.ВидыНазначенияДатЗапрета.ДляВсехПользователей)";
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
	ДатаНачала = ВыборкаДетальныеЗаписи.ДатаЗапрета;
КонецЦикла;
ДатаОкончания = ТекущаяДата();
ДатаОкончанияКонецДня = КонецДня(ДатаОкончания)+1;

ДатаВыгрузки  = Формат(ДатаОкончания, "ДФ=yyyy.MM.dd_hh.mm.ss");
ПутьНаДиске   = "\\server1c\obmen\";
ФайлПравил    = ПутьНаДиске  + "ПравилаВыгрузкиBuh.xml";
ФайлДанных    = ПутьНаДиске  + ДатаВыгрузки + "_DataBuh.xml";

МассивВыгружаемыхОбъектов = Новый Массив;	
МассивВыгружаемыхОбъектов.Добавить("Документ.РеализацияТоваровУслуг");		
МассивВыгружаемыхОбъектов.Добавить("Документ.ПриобретениеТоваровУслуг");
МассивВыгружаемыхОбъектов.Добавить("Документ.ПеремещениеТоваров");
МассивВыгружаемыхОбъектов.Добавить("Справочник.ДоговорыКонтрагентов");	
МассивВыгружаемыхОбъектов.Добавить("Справочник.Контрагенты");	
МассивВыгружаемыхОбъектов.Добавить("Справочник.Номенклатура");		
                                                                          
УзелВыгрузки = ПланыОбмена.ВыгрузкаВБазуБП.НайтиПоНаименованию("Выгрузка");
УзелИзменения = ПланыОбмена.ВыгрузкаВБазуБП.НайтиПоНаименованию("Изменения");

 

2. - Формирую запрос к изменениям в узле "Изменения". (намерено не пользуюсь функцией ВыбратьИзменения, чтобы избежать "Конфликта блокировок")

- Удаляю регистрацию с узла "Изменения" и регистрирую в узел "Выгрузка"

 

 

Запрос = Новый Запрос;
текстОбъединить = "";
Для Каждого текО Из МассивВыгружаемыхОбъектов Цикл
	текстИзменения = " 
	|ВЫБРАТЬ
	|	тИзменения.Ссылка КАК Ссылка,
	|	тИзменения.Узел КАК УзелИзменений
	|ИЗ
	|	%Объект%.Изменения КАК тИзменения
	|ГДЕ
	|	тИзменения.Узел = &УзелИзменения
	|";
	текстИзменения = СтрЗаменить(текстИзменения, "%Объект%", текО);
	Запрос.Текст = Запрос.Текст + текстОбъединить + текстИзменения;
	текстОбъединить = "
	|
	|ОБЪЕДИНИТЬ ВСЕ
	|
	|";
КонецЦикла;
Запрос.УстановитьПараметр("УзелИзменения",УзелИзменения);
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
	Если НЕ ПланыОбмена.ИзменениеЗарегистрировано(УзелВыгрузки, ВыборкаДетальныеЗаписи.Ссылка) Тогда
		ПланыОбмена.ЗарегистрироватьИзменения(УзелВыгрузки, ВыборкаДетальныеЗаписи.Ссылка);
	КонецЕсли;
	ПланыОбмена.УдалитьРегистрациюИзменений(УзелИзменения, ВыборкаДетальныеЗаписи.Ссылка);
КонецЦикла;

 

3. -Сохраняю файл с Правилами обмена данными на диск

- Создаю Обработку УниверсальныйОбменДаннымиXML, заполняю необходимые для обмена параметры

- после выгрузки Удаляю файл с Правилами обмена с диска 

 

 

ДвоичныеДанные = ПолучитьМакет("Правила");
Попытка
    ДвоичныеДанные.Записать(ФайлПравил);
Исключение
	ЗаписьЖурналаРегистрации("Выгрузка в бухгалтерию",
		УровеньЖурналаРегистрации.Ошибка,
		Метаданные.Обработки.УниверсальныйОбменДаннымиXML,
    	Неопределено,
    	ОписаниеОшибки());
	Возврат;
КонецПопытки;

Обработка = Обработки.УниверсальныйОбменДаннымиXML.Создать();
Обработка.РежимОбмена = "Выгрузка";
Обработка.ВыводВОкноСообщенийИнформационныхСообщений = Ложь;
Обработка.ДатаНачала     = ДатаНачала;
Обработка.ДатаОкончания  = ДатаОкончанияКонецДня;
Обработка.ИмяФайлаПравилОбмена = ФайлПравил;
Обработка.ИмяФайлаОбмена = ФайлДанных; 
Обработка.ЗагрузитьПравилаОбмена();
Обработка.ВыполнитьВыгрузку();

Попытка
	УдалитьФайлы(ФайлПравил);  
Исключение
	Сообщить(ОписаниеОшибки());
КонецПопытки;

 

4. В Конвертации данных 2.1: 

 

 Перед выгрузкой данных определяем параметр узел "Выгрузка"

В правилах выгрузки данных каждого объекта (Перед обработкой):

В правилах конвертации объекто: в событии "При выгрузке" при удачной выгрузке удаляю регистрацию из узла "Выгрузка"

В итоге получаю файл с данными.

 

5. -Для загрузки файла в базе "Приемник" делаем такую же обработку. Также подключаем ее, чтобы она запускалась по расписанию.

-Для загрузки "Правила обмена данными" не нужны. Создаем Обработку УниверсальныйОбменДаннымиXML и загружаем файл.

-После удачной загрузки сам файл перемещаем в папку "Downloaded"

 

 

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды = Неопределено) Экспорт
	
	ПутьНаДиске   = "\\server1c\obmen\";
	табФ = Новый ТаблицаЗначений;
	табФ.Колонки.Добавить("Путь");
	табФ.Колонки.Добавить("Имя");
	табФ.Колонки.Добавить("Диск");
	МассивФайлов = НайтиФайлы(ПутьНаДиске, "*.xml", Ложь);
	Если Не МассивФайлов.Количество() Тогда
		Возврат;
	КонецЕсли;
	Для Каждого текФ Из МассивФайлов Цикл
		НоваяСтр = табФ.Добавить();
		НоваяСтр.Путь = текФ.Путь;
		НоваяСтр.Имя  = текФ.Имя;
		НоваяСтр.Диск = текФ.ПолноеИмя;
	КонецЦикла;
	
	Обработка = Обработки.УниверсальныйОбменДаннымиXML.Создать();
	Для Каждого текСтр Из табФ Цикл
		Обработка.РежимОбмена = "Загрузка";
		Обработка.ИмяФайлаОбмена = текСтр.Диск;
		Обработка.ЗагружатьДанныеВРежимеОбмена = Истина;
		Обработка.ЗаписыватьВИнформационнуюБазуТолькоИзмененныеОбъекты = Истина;
		Обработка.ОбъектыПоСсылкеЗагружатьБезПометкиУдаления = Истина;
		Обработка.ОптимизированнаяЗаписьОбъектов = Истина;
		Обработка.ЗаписыватьРегистрыНаборамиЗаписей = Истина;
		Обработка.ОбрезатьСтрокиСправа = Истина;
		Обработка.ВыполнитьЗагрузку();
		ПереместитьФайл(текСтр.Диск, текСтр.Путь + "Downloaded\" + текСтр.Имя);
	КонецЦикла;
	
КонецПроцедуры

 

 
 Полный текст процедуры ВыполнитьКоманду (Выгрузка)

Тестировал на платформе 1С:Предприятие 8.3 (8.3.15.1747)

1С:Комплексная автоматизация 2 (2.4.9.98)

Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.74.63).

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. PLAstic 225 22.01.20 14:22 Сейчас в теме
А какова прикладная задача была?
2. John_d 2137 22.01.20 14:51 Сейчас в теме
(1) Настроить односторонний обмен (через конвертацию) между двумя базами
12. PLAstic 225 23.01.20 09:21 Сейчас в теме
(2) А почему нельзя было просто встроить свой план обмена в существующий механизм?
3. Kaval88 69 22.01.20 15:26 Сейчас в теме
на БСП проще сделать, только правила загрузить и все.
ivanov660; +1 Ответить
15. Pipapalamm 23.01.20 11:45 Сейчас в теме
(3) Подскажите пожалуйста, как можно правила конвертации 2.1 "загрузить" в БСП? Реально появилась такая возможность? Где почитать? А то на Инфостарте полно вот такого рода публикаций:
https://infostart.ru/public/461158/
"а мужики то не знают..."
16. John_d 2137 23.01.20 11:49 Сейчас в теме
(15) Нельзя. Нужно дорабатывать конфигурацию.
Pipapalamm; +1 Ответить
21. glime 95 23.01.20 14:34 Сейчас в теме
(16)в легкую можно.
во внешнею обработку, в макет.
18. wtlz 28 23.01.20 12:12 Сейчас в теме
(15)можно использовать правила из файла:
Прикрепленные файлы:
19. Pipapalamm 23.01.20 12:32 Сейчас в теме
(18) Это правила КД 3. Мы говорим про обмен по правилам КД 2.
20. wtlz 28 23.01.20 12:36 Сейчас в теме
(19) КД 2 работает через это отлично, проверял лично, БСП 3.0.1.53
Pipapalamm; +1 Ответить
22. Pipapalamm 23.01.20 16:07 Сейчас в теме
(20) Ничоси! Проверю обязательно и выкину наконец свои велосипеды. Спасибо огромное!
4. dsdred 1313 22.01.20 16:29 Сейчас в теме
1 Нет проверки на удаленные объекты(битые ссылки). При попадании такого объекта обмен встанет.

2 Почему не использовать"ПланыОбмена.ВыбратьИзменения"?
ПланыОбмена.ВыбратьИзменения позволяет более гибко делать, меньше кода и проще проверять битые ссылки.

3 Почему XML, а не JSON?
XML очень жирный...

4 Два узла на один обмен...

КД 2.1, файлы, xml, два узла... по мне больше на костыль похоже чем на нормальное решение.
Светлый ум; Xershi; acanta; +3 Ответить
5. John_d 2137 22.01.20 16:38 Сейчас в теме
(4) по 2 пункту много где писали.
ВыбратьИзменения() – это метод, с которым нужно быть очень осторожным, потому что обычно, когда возникают проблемы с производительностью обменов, именно из-за этого вызова возникают блокировки.
https://infostart.ru/public/899200/
байт; +1 Ответить
7. John_d 2137 22.01.20 16:50 Сейчас в теме
(4)
1. согласен, надо сделать.
3. Конвертация Данных 3 тоже через XML.
4. выше писал для чего это делаю.
8. dsdred 1313 22.01.20 17:05 Сейчас в теме
(7)Я понимаю для чего. Я не понимаю почему именно КД.
Наверное фирма с небольшим документооборотом?

П.С. Не обращайте внимание на мои придирки. Просто дописываю мобильное приложение и не типовой обмен на http-сервисах и Вы прям на больную мозоль написали ;))
9. John_d 2137 22.01.20 17:22 Сейчас в теме
(8) КД 2 наименее трудозатратно. Кода минимум, одна процедура на выгрузку и одна на загрузку. Остальное отрабатывает КД 2.
11. байт 27 23.01.20 08:36 Сейчас в теме
(4) по 2-му пункту ВыбратьИзменения опасен тем что он не только читает изменения, но и записывает номера сообщений в записи регистрации изменений у которых номер сообщения null, все это в одной транзакции в следствии чего возникают избыточные блокировки. Ед. в выборке можно было в цикле открывать маленькие транзакции т.е разбить большую на маленькие. Это все выжимка из курса "1С:Эксперт" Виктора Богачева.
13. dsdred 1313 23.01.20 11:12 Сейчас в теме
(11)Это все понятно и в жизни я как раз разбиваю на небольшие порции.
Просто по публикации автора я понял, что обмен идет в одну сторону в одну базу и с довольно таки малым документооборотом.
Поэтому и предполагаю, что проблемы с организацией обмена через ПланыОбмена.ВыбратьИзменения быть не должно.
14. John_d 2137 23.01.20 11:16 Сейчас в теме
(13) Документооборот нормальный и как правило со временем он растет. С ВыбратьИзменения проблемы будут.
17. dsdred 1313 23.01.20 11:55 Сейчас в теме
(14)Тогда к сожалению я тем более не могу понять почему выбран такой подход к решению задачи.
6. acanta 73 22.01.20 16:46 Сейчас в теме
И при последних релизах БСП идентификации по гуид все равно отсутствуют.
10. metmetmet 75 23.01.20 06:54 Сейчас в теме
Для работы достаточно одной обработки Универсальный Обмен Данными XML в базе источнике и в базе приемнике? Или есть зависимые общие модули?
23. nt_ 31.01.20 12:29 Сейчас в теме
Не понял только где назначается узел обмена "Выгрузка" при обращении к обработке УниверсальныйОбменДаннымиXML?
24. John_d 2137 31.01.20 16:07 Сейчас в теме
(23) В КД 2. Перед выгрузкой данных:
 
Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ ПЕРВЫЕ 1
|	АТИ_ВыгрузкаВБазуБП.Ссылка КАК Узел
|ИЗ
|	ПланОбмена.ВыгрузкаВБазуБП КАК АТИ_ВыгрузкаВБазуБП
|ГДЕ
|	АТИ_ВыгрузкаВБазуБП.Наименование = ""Выгрузка""";
РезультатЗапроса = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
	Параметры.УзелРегистрацииВыгруженных = ВыборкаДетальныеЗаписи.Узел;
КонецЦикла;
 
Показать
25. nt_ 01.02.20 03:48 Сейчас в теме
(24) Это для удаления регистрации источника. А как натравить обработку на обход элементов узла "выгрузка"? у меня все объекты выгружает по правилу, а не только зарегистрированные.
26. John_d 2137 03.02.20 09:58 Сейчас в теме
(25) При выгрузке данных.. Упустил этот момент. Дописал статью.
Оставьте свое сообщение

См. также

[БСП] Обмен через Конвертацию данных 2.1

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Обмен через XML

Добавим новый план обмена и настроим в БСП типовой обмен через правила конвертации данных (КД 2.1)

03.02.2020    3535    John_d    16       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Как сделать обмен данными через универсальный формат быстрее? Реализация многопоточного обмена данными

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Обмен данными 1С Обмен через XML

Предлагаю Вашему вниманию интересный кейс по реализации обмена данными через универсальный формат между современными типовыми конфигурациями в режиме многопоточности. Учитывая все тонкости механизмов обмена данными и сложности типовых правил конвертации, сделать это оказалось совсем не так просто.

31.12.2019    4233    ids79    15       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Универсальные функции Обмен через XML

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    6005    kraspila    27       

Доработка конвертации данных КД2 (версии 2.1). Расширенная диагностическая информация при выгрузке по правилам из 1С 7.7 и при загрузке в 1С 7.7

Статья Программист Нет файла v7.7 v8 КД Бесплатно (free) Обмен данными 1С Перенос данных из 1С7.7 в 1C8.X Обмен через XML

Есть очень неприятная особенность при настройке обмена по правилам КД2 в момент отладки на стороне 1С 7.7, как при выгрузке из 1С 7.7, так и при загрузке в 1С 7.7. Непонятно, в каком конкретно месте формирования или разбора данных XML файла в какой именно момент споткнулась программа (произошел сбой). Я нашел способ вывода дополнительной диагностики, теперь точно известно, на каком элементе данных XML споткнулся модуль выгрузки V77Exp.ert (модуль загрузки V77Imp.ert). Теперь отладка правил обмена на стороне 1С 7.7 стала простой, выполняется на порядок проще.

18.10.2019    2957    ksnik    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Практика XDTO. Нюансы

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Обмен через XML

Некоторые практические моменты работы с XDTO. Дополнения к очевидному.

23.09.2019    6911    Yashazz    27       

Запись/Чтение XML, пример обмена по COM соединению

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Обмен через XML

Пример работы с XML, запись и чтение, обмен по COM между одинаковыми конфигурациями.

08.09.2019    5174    user5300    7       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Конвертация данных 2.0. Перенос справочника с иерархией групп и элементов

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Обмен через XML

Детективная история о том, как при переносе элементы справочника становились не "видимыми".

09.08.2019    2677    chagbig    4       

Загрузка данных в БП 3.0 (Универсальный обмен данными XML)

Статья Программист Нет файла v8::БУ БП3.0 БУ Бесплатно (free) Обмен через XML

Решение задачи по загрузке данных из имеющегося файла в формате xml в БП 3.0 (в том числе на 1cfresh.com) без доработок

26.05.2019    2900    rutadmeen    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Конвертация 3.0. Пример доработки: два справочника в один

Статья Программист Нет файла v8 КД ERP2 БП3.0 Россия Бесплатно (free) Обмен через XML

Доработка правил конвертации путем расширения конфигурации: номенклатура и характеристика (ERP) в номенклатуру (БП).

15.05.2019    4945    forusing    4       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Обмен данными между УПП 1.3.64.х и БП 3.0 по расписанию через Универсальный обмен данными + План обмена

Статья Программист Нет файла v8 УПП1 Россия Windows Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

Описание доработки конфигурации УПП 1.3.64.х для выполнения обмена данными по расписанию в БП 3.0. через обработку Универсальный Обмен Данными XML и План Обмена.

09.04.2019    4399    mrcamomile    6       

RabbitMQ + Конвертация Данных 3.0

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    18097    barelpro    82       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

EnterpriseData – часть 2. Процесс выгрузки данных

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    18278    ids79    27       

Неполадки в работе функционала конфигурации "Бухгалтерия предприятия 3.0" после переноса данных из одной конфигурации в другую через XML

Статья Программист Нет файла v8 БП3.0 Россия Бесплатно (free) Обмен через XML

«Подводные камни» в работе конфигурации «Бухгалтерия предприятия 3.0» после переноса данных из одной конфигурации в другую средствами XML.

18.12.2018    3437    faust0923    1       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Новый подход к обмену данными EnterpriseData

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    28969    ids79    72       

MDM система для централизованного управления справочниками предприятия типовыми средствами

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Обработка справочников Обмен через XML

Поставили мне пару недель назад задачу настроить единые справочники номенклатуры во всех базах холдинга. Учитывая количество 1С бухгалтерий, которых в процессе выполнения задачи оказалось 32, и учитывая, что они все разных версий (2.0, 3.0, отраслевые), задача казалась из ряда чистой воды подстава. Но решение с технической точки зрения оказалось простейшим.

27.11.2018    4542    lopatin    5       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    25646    ids79    20       

Свертка номенклатуры при выгрузке из Управления Торговлей 11 в Бухгалтерию 3.0

Статья Программист Нет файла v8 БП3.0 УТ11 БУ УУ Бесплатно (free) Обмен через XML

Свертка номенклатуры при выгрузке из УТ 11 в Бухгалтерию 3. Используется типовой обмен на базе EnterpriseData

20.07.2018    8133    Kutuzov    3       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Обмен через универсальный формат. Пример нестандартной конвертации данных

Статья Программист Нет файла v8 УТ11 Россия Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    27942    artkor    12       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Конвертация данных. Выгрузка контактной информации из регистра сведений в табличную часть

Статья Программист Нет файла v8 КД Бесплатно (free) Обмен через XML

Довольно часто встречается задача выгрузить при помощи «Конвертация данных, редакция 2.1» контактной информации контрагента из «Управление торговлей", редакция 10.3» в «Бухгалтерия предприятия, редакция 3.0». Сложность заключается в том, что в УТ контактная информация хранится в регистре сведений, а в БП - в табличной части справочника «Контрагенты». Предлагаю мое, достаточно простое, решение данной задачи.

11.12.2017    17977    Nicholas    9       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена)

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    159956    MaxS    259       

Что такое конвертация данных 1С (статья написана исключительно для новичков)

Статья Программист Стажер Нет файла v8 КД Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

О том, что "Конвертация данных" - мощный инструмент и прочую терминологию, вы прочтёте в любом источнике. Я хочу поделиться кратким пояснением как пользоваться данной конфигурацией. Речь пойдет о версии 2.1.

07.08.2017    33066    perepetulichka    38